Delayed withdrawals in Nigeria
Incident Report for
Luno
Resolved
Withdrawals are no longer delayed and should be working as normal.
We appreciate your understanding in this matter.
Posted
Jun
01
,
2025
-
10:45
UTC
Identified
We have identified an issue causing withdrawal delays.
Customers may see longer-than-normal processing times when initiating a withdrawal via bank transfer
Unfortunately, this issue is with our payment provider, We are working closely with them to resolve this as soon as possible.
We appreciate your understanding and apologize for any inconvenience this may cause.
Posted
May
31
,
2025
-
22:08
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed withdrawals in Nigeria
via . You'll receive .