Delayed bank deposits and withdrawal in ZA
Incident Report for Luno
Resolved
This issue has been resolved. Payments should reflect today, 23 March.
Posted Mar 23, 2020 - 06:00 UTC
Identified
Deposits and withdrawals in South Africa will not be processed on 21 March due to the public holiday. Unfortunately, banks do not process deposits and withdrawals over weekends or public holidays.

Deposits and requested withdrawals will be processed on 23 March.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Mar 21, 2020 - 13:04 UTC