Account recovery on Android
Incident Report for Luno
Resolved
This has been fully resolved. Please ensure that you have the latest version of our app installed.
Posted Oct 26, 2020 - 12:41 UTC
Monitoring
This has been resolved in the latest version available via the Play Store. Please ensure that you are on the latest version, 7.0.2 or above. If you continue to experience issues recovering your account via Android please reach out to our team.
Posted Oct 09, 2020 - 14:42 UTC
Update
We are continuing to work on a fix for this issue. We will update this incident once an updated version has reached the Play Store.
Posted Oct 08, 2020 - 09:22 UTC
Identified
We have identified an issue with "Having Trouble?" recovery flows in the sign in screen on Android. You may experience a blank screen when trying to recover your account or being looped back to the sign up screen. We are currently working on a fix for this.

As a work around you can recover your account using our website.
Posted Oct 07, 2020 - 06:58 UTC