Delayed bank withdrawals in Malaysia
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 7 months ago. Feb 08, 2019 - 11:44 UTC
Identified
Withdrawals in Malaysia will not be processed on the below dates due to the public holidays, unfortunately banks do not process withdrawals over weekends or public holidays.

1 February 2019
5 February 2019
6 February 2019

Requested withdrawals on these dates will be processed the next business day.
Please view our full withdrawal schedule via the link below:

https://www.luno.com/help/articles/11000022934
Posted 7 months ago. Jan 31, 2019 - 12:32 UTC