Delayed bank withdrawals in Malaysia
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted Sep 10, 2019 - 11:00 SAST
Investigating
Withdrawals in Malaysia will not be processed on 9 September 2019 due to the public holiday, unfortunately banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 10 September 2019.

Please view our full withdrawal schedule via the link below:

https://www.luno.com/help/articles/11000022934
Posted Sep 09, 2019 - 08:27 SAST
This incident affected: Bank deposits and withdrawals (Malaysia).