Delayed bank withdrawal in Europe
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Apr 06, 2021 - 08:46 UTC
Identified
Withdrawals in Europe will not be processed on 2 April 2021 due to the public holiday, unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 5 April 2021.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Apr 01, 2021 - 09:20 UTC