Delayed bank withdrawal in Malaysia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Oct 30, 2020 - 06:33 UTC
Identified
Withdrawals in Malaysia will not be processed on 29 October 2020 due to the public holiday, unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 30 October 2020.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Oct 27, 2020 - 09:53 UTC