Delayed Payout for DOT Rewards
Incident Report for
Luno
Resolved
This issue has now been resolved.
Posted
Oct
17
,
2025
-
07:01
UTC
Identified
We're currently experiencing a technical issue which is causing DOT reward payouts to be delayed. We're urgently working on resolving this issue and will provide further updates as soon as possible. Thank you for your patience.
Posted
Oct
16
,
2025
-
12:46
UTC
×
Subscribe to Incident
Subscribe to updates for
Delayed Payout for DOT Rewards
via . You'll receive .