Slow crypto sends
Incident Report for Luno
Resolved
Send transactions have returned to normal.
Posted Apr 19, 2021 - 07:33 UTC
Identified
We've identified a small backlog of send transactions affecting BTC, LTC, BCH, XRP and USDC. Customers may see a slight delay in their sends being processed.
Posted Apr 19, 2021 - 05:32 UTC
This incident affected: Crypto sends and receives (BTC, BCH, XRP, LTC, USDC).