Delayed bank deposits and withdrawal in South Africa
Incident Report for Luno
Resolved
Withdrawals are being processed as scheduled.

Thank you.
Posted Jun 17, 2020 - 06:13 UTC
Identified
Withdrawals in South Africa will not be processed on 16th June due to the public holiday, unfortunately, banks do not process withdrawals over weekends or public holidays. The public holiday may also delay deposit reflection time.

Requested withdrawals will be processed on 17th of June.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Jun 13, 2020 - 07:05 UTC