Maintenance for NGN deposits in Nigeria
Incident Report for Luno
Resolved
Deposits are being processed as normal.
Posted 11 days ago. Oct 06, 2019 - 19:01 SAST
Investigating
Deposits to your Luno NGN wallet will be temporarily unavailable due to bank system maintenance.

Deposits will be available again once the maintenance window is complete.
Posted 13 days ago. Oct 04, 2019 - 17:46 SAST
This incident affected: Bank deposits and withdrawals (Nigeria).