Account verification delays
Incident Report for Luno
Resolved
Account verification times have returned to normal.
Posted 6 months ago. Jan 16, 2018 - 07:06 UTC
Update
We have doubled our verification capacity and continue to aggressively hire and optimise our verification system. Customers may continue to experience verification wait times that are longer than usual. We are working on normalising the situation. Updates to follow. We apologise for any inconvenience caused.
Posted 6 months ago. Jan 04, 2018 - 13:46 UTC
Identified
Around the world, we are seeing an exponential increase in interest in digital currencies like Bitcoin (and Luno).
We are seeing record numbers of customers signing up with Luno and attempting to get verified or reaching out to us with requests for information. This means that our responses and resolution time for these requests have been slower than normal.
We are working around the clock to verify as many customers as fast as possible and clearing all outstanding tickets.
We are hiring fast and taking immediate steps to triple our verification capacity in the coming weeks. Updates to follow.
Posted 7 months ago. Dec 08, 2017 - 14:03 UTC