Slow email response times
Incident Report for Luno
Resolved
While the backlog has eased somewhat, we're still not able to get back to everyone in the timeframe that we'd like.
We're working on better ways to notify customers of any further potential delays.

Thanks again for everyones patience.
Posted Apr 02, 2020 - 16:05 UTC
Identified
We're still seeing some delays in getting back to everyone, a small backlog has developed over the weekend however we're working as quickly as possible to minimise response times.

Thanks again for your patience.
Posted Mar 23, 2020 - 06:44 UTC
Investigating
If you’ve recently contacted us we may take longer than usual to get back to you.

We’re experiencing higher than normal email volumes which may result in a slower than normal response time. We’re working through the backlog as quickly as we can.

Please bear with us while we work on getting back to you.
Posted Mar 09, 2020 - 13:14 UTC