Delayed withdrawals
Incident Report for Luno
Resolved
The issue affecting delayed withdrawals has been resolved.

We apologise for any inconvenience caused.
Posted Apr 25, 2024 - 13:43 UTC
Monitoring
Withdrawals are now being processed as normal. We will continue to monitor for any further issues.
Posted Apr 25, 2024 - 12:25 UTC
Identified
The issue has been identified. Some customers may still see delayed bank withdrawals. We are continuing to work on this as a priority.
Posted Apr 25, 2024 - 10:46 UTC
Investigating
We are currently investigating an issue which may be causing temporary delays with bank withdrawals.

We’re working on resolving this as a matter of priority.
Posted Apr 25, 2024 - 09:19 UTC