Issue has been resolved, customers are now able to use instant buy/sell without any delays. We thank you for your patience
Posted Oct 12, 2025 - 07:37 UTC
Identified
We have identified an issue where our instant buy/sell is degraded due to our market volatility. Customers may experience delays in instant buy/sell. We apologise for any inconvenienced caused.