Crypto Twitter Warning
Incident Report for Luno
Resolved
Twitter will continue to provide updates on their investigation.

Learn more about how to safeguard your crypto assets:
https://www.luno.com/help/articles/11000077349

Stay vigilant.
Posted Jul 17, 2020 - 11:58 UTC
Monitoring
Twitter has mitigated the compromised accounts and will be investigating the incident.

Please stay vigilant.
Posted Jul 16, 2020 - 10:21 UTC
Identified
WARNING

It appears a number of crypto Twitter accounts have been compromised, offering Bitcoin to the community.

Please be vigilant and DO NOT send crypto to any advertisements or giveaways
Posted Jul 15, 2020 - 20:34 UTC