Delayed bank withdrawal in Indonesia
Incident Report for Luno
Resolved
Withdrawals are now being processed according to schedule.

Thank you.
Posted May 26, 2020 - 06:26 UTC
Identified
Withdrawals in Indonesia will not be processed on 21, 22 and 25 May due to the public holiday, unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 26 May

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted May 20, 2020 - 06:19 UTC