Bank deposits in Nigeria
Incident Report for Luno
Resolved
Deposits are being processed as normal.
Posted 4 months ago. May 15, 2018 - 12:09 UTC
Identified
We've identified an issue affecting some customers in Nigeria using GT Collections to deposit NGN. Our team are aware of this and are investigating.

Updates to follow shortly.
Posted 4 months ago. May 15, 2018 - 09:07 UTC
This incident affected: Bank deposits and withdrawals (Nigeria).