Delayed bank withdrawal in Indonesia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Jan 04, 2021 - 03:57 UTC
Identified
Withdrawals in Indonesia will not be processed from 30th December 2020, 12.30PM WIB time due to the public holiday. Unfortunately, banks do not process withdrawals over weekends and public holidays.

Requested withdrawals will be processed on 4th January 2021.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Dec 30, 2020 - 04:39 UTC