Delayed bank withdrawals in Nigeria
Incident Report for Luno
Resolved
All withdrawals are being processed as normal.
Posted 2 months ago. Aug 05, 2019 - 16:45 SAST
Investigating
Due to a technical problem on the banking platform we make use of, withdrawals requested to GT bank, Stanbic and Standard Charter may be delayed.

We're hoping to see this resolved during our next withdrawal release, times for this can be found below.
https://www.luno.com/help/articles/11000022934
Posted 2 months ago. Aug 05, 2019 - 10:20 SAST
This incident affected: Bank deposits and withdrawals (Nigeria).