Slow account verifications
Incident Report for Luno
Resolved
Account verification times have returned to normal.
Posted Apr 27, 2021 - 18:32 UTC
Identified
We've identified a backlog of customers who are stuck on a verification step due to an issue on our system. Customers that signed up and attempted to verify their accounts between 09:00 UTC on 23 April 2021 and 12:00 UTC on 26 April 2021 are seeing a slower than usual turn around time.

A fix has already been implemented and we're seeing some customers accounts verified, however the backlog may take up to 48 hours to complete.

Updates to follow, thanks for your patience.
Posted Apr 26, 2021 - 13:46 UTC
This incident affected: Help & account verification (Account verification).