Slow bank withdrawals in Nigeria
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 3 months ago. Dec 19, 2018 - 07:31 UTC
Identified
There will be a slight delay with Nigerian bank withdrawals requested on 18 December 2018. This is a temporary incident which we hope to see resolved during the day. We will re-attempt to release the withdrawals during the next release, you can find the full schedule here - https://www.luno.com/help/en/articles/11000022934

Updates to follow.
Posted 3 months ago. Dec 18, 2018 - 10:52 UTC
This incident affected: Bank deposits and withdrawals (Nigeria).