luno.com Website Intermittent Connection
Incident Report for Luno
Resolved
All services have returned to normal.
Posted 2 months ago. Jun 24, 2019 - 12:51 UTC
Update
We are continuing to investigate this issue.
Posted 2 months ago. Jun 24, 2019 - 11:08 UTC
Investigating
Our team are investigating an issue causing our website, luno.com to be intermittent.
This will affect our website and public API.

We're working on this as a priority, updates to follow soon.
Posted 2 months ago. Jun 24, 2019 - 11:05 UTC
This incident affected: Website and API.