Slow Deposits in Nigeria
Incident Report for Luno
Resolved
This issue has been resolved.

Thank you.
Posted Sep 21, 2020 - 06:28 UTC
Investigating
We're aware that Flutterwave Pay with Bank deposits are currently unavailable due to maintenance issues. We hope to have this resolved soon. In the meantime, please make use of an alternative deposit method in your Luno wallet.

Thank you.
Posted Sep 16, 2020 - 10:03 UTC