Luno exchange errors
Incident Report for Luno
Resolved
No further errors are being reported, we'll continue to monitor for any further anomalies.

Thanks again for everyone's patience.
Posted Nov 12, 2020 - 09:09 UTC
Identified
We've identified the issue and are working on a fix, error rates are coming down slowly.
Posted Nov 12, 2020 - 06:50 UTC
Investigating
We're investigating elevated errors on the Exchange.

Our team are working on this as a priority.
Posted Nov 12, 2020 - 06:21 UTC