Promotional code redemption delays

Incident Report for Luno

Resolved

The issue affecting promotional and referral code redemptions has been resolved. Redemptions are now working normally.

Thank you for your patience.
Posted Apr 14, 2025 - 07:15 UTC

Identified

We are currently experiencing an issue that may cause delays when redeeming promotional codes. Our team is aware and actively working to resolve this as a priority.
Posted Apr 14, 2025 - 06:41 UTC