Delayed bank withdrawals in Europe
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted Oct 18, 2019 - 14:41 SAST
Investigating
There will be a slight delay with European bank account withdrawals requested on 18 October 2019. This is a temporary incident which we hope to see resolved during the day. We will re-attempt to release the withdrawals during the next release, you can find the full schedule here - https://www.luno.com/help/en/articles/11000022934

Updates to follow.
Posted Oct 18, 2019 - 08:28 SAST
This incident affected: Bank deposits and withdrawals (Europe).