PayU Instant EFT deposits temporarily unavailable
Incident Report for Luno
Resolved
The issue has been resolved and PayU deposits are now being processed successfully.
Posted May 08, 2022 - 08:24 UTC
Investigating
We are currently investigating an issue causing instant EFT deposits with PayU to fail for some customers.

We are working to get this issue resolved as a priority, In the meantime, please make use of an alternative deposit method in your Luno wallet.
Posted May 08, 2022 - 07:50 UTC
This incident affected: Bank deposits and withdrawals (South Africa, Nigeria).