Unable to submit tickets
Incident Report for Luno
Resolved
The issue has been resolved. Support tickets can be created as normal.
Posted Aug 24, 2021 - 13:12 UTC
Monitoring
Our team have resolved the issue and are monitoring the results, support tickets can be created as normal.

Thanks for your patience.
Posted Aug 24, 2021 - 12:26 UTC
Identified
We have identified the issue and we are implementing a fix to resolve this.
Posted Aug 24, 2021 - 12:13 UTC
Investigating
We have identified an issue where customers are unable to submit tickets to our team.

We're investigating urgently.
Posted Aug 24, 2021 - 12:07 UTC
This incident affected: Help & account verification (Support response times).