Delayed Trades
Incident Report for Luno
Resolved
This issue has been resolved and we are no longer seeing any delays.
Posted Jul 14, 2022 - 07:09 UTC
Monitoring
A fix has been implemented for this, we will continue to monitor for any further anomalies.
Posted Jul 13, 2022 - 18:00 UTC
Investigating
We are currently experiencing an issue with some trades on our exchange being delayed.

We are investigating this issue as a priority and will provide updates as soon as we can.
Posted Jul 13, 2022 - 12:27 UTC