Delayed bank withdrawal in Malaysia
Incident Report for Luno
Resolved
Withdrawals are now being processed as scheduled. Thank you
Posted Aug 11, 2021 - 02:13 UTC
Update
We are continuing to work on a fix for this issue.
Posted Aug 09, 2021 - 10:23 UTC
Identified
Withdrawals in Malaysia will not be processed on 10th August due to the public holiday, unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 11th August.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Aug 09, 2021 - 10:18 UTC