Slow Bitcoin transactions
Incident Report for Luno
Resolved
Bitcoin transaction times have stabilised over the last 24 hours, we'll continue to monitor.
Posted Sep 23, 2020 - 06:42 UTC
Monitoring
Transaction times have returned to normal, we'll continue to monitor closely.
Posted Sep 22, 2020 - 06:25 UTC
Identified
Slower block times as well as a spike in fees has resulted in a backlog of transactions on the Bitcoin blockchain. Unfortunately this is something that is out of Luno's hands. We'll continue to monitor transaction throughput.
Posted Sep 21, 2020 - 14:58 UTC