Error placing orders on the exchange in Indonesia
Incident Report for Luno
Resolved
Placing orders on exchange has returned to normal. We apologize for any inconvenience this may have caused.
Posted Aug 01, 2022 - 10:17 UTC
Investigating
We are currently aware of an issue that may be causing errors to some customers placing orders on the exchange. Our team is aware of this and working to get this resolved.

Updates to follow.
Posted Aug 01, 2022 - 08:26 UTC