Slow Bank Deposits in Australia
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Sep 03, 2021 - 02:07 UTC
Monitoring
The issue with our provider services has resolved and we are currently monitoring the results.
Posted Sep 02, 2021 - 06:37 UTC
Investigating
We are aware that some of you may be experiencing a delay with your deposits. Rest assured as our team is currently investigating it. Deposits via PayID and NPP, however, are working normally.

We will provide an update once the issue has been resolved.

Thank you.
Posted Sep 01, 2021 - 14:07 UTC