Delayed bank withdrawals in Zambia
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted Sep 08, 2020 - 13:23 UTC
Identified
There are temporary delays with Zambia withdrawals. We’re working with the bank to see this resolved soon.
Posted Sep 01, 2020 - 17:08 UTC