Delayed crypto sends

Incident Report for Luno

Resolved

Crypto sends are now processing successfully. We will continue monitoring for any further issues.
Posted May 28, 2026 - 07:59 UTC

Identified

We have identified an issue that may be causing delayed crypto sends for some customers in the following regions: South Africa, Malaysia, Nigeria, and the United Kingdom.

Customers in the affected regions may experience longer than usual processing times for crypto sends during this period.

We will provide further updates as soon as more information becomes available. Thank you for your patience and understanding.
Posted May 28, 2026 - 01:01 UTC