Delayed bank withdrawals in Nigeria
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Jul 24, 2020 - 10:07 UTC
Update
This issue has been resolved. Thank you for your patience.
Posted Jul 24, 2020 - 07:11 UTC
Identified
There may be temporary delays with withdrawals in Nigeria requested on 22nd July. We’re working with our provider to see this resolved soon.

We will attempt to release the withdrawals during the next release. You can find the full withdrawal schedule here: https://www.luno.com/help/articles/11000022934
Posted Jul 22, 2020 - 07:44 UTC