Delayed bank withdrawals in South Africa
Incident Report for Luno
Resolved
The incident has been resolved and customers should be able to view updated wallet balances.
Posted Nov 03, 2021 - 07:43 UTC
Monitoring
We have managed to identify and fix the issue. Our engineers are still monitoring the progress to ensure that we are back to normal shortly. Thank you for for your patience.
Posted Nov 03, 2021 - 06:09 UTC
Update
Unfortunately, the issue persists and we're still working to ensure it gets fixed.
Posted Nov 02, 2021 - 19:37 UTC
Investigating
We are investigating an issue where customers' deposits and withdrawals have been processed successfully but not reflected and updated on their Luno wallet balances. Our team is aware and working on getting this resolved urgently.
Posted Nov 02, 2021 - 14:10 UTC
Monitoring
Bank withdrawals have started to process normally and we are monitoring the progress to ensure optimal performance. Thank you for being patient
Posted Nov 02, 2021 - 13:20 UTC
Investigating
We are experiencing temporary delays with bank withdrawals requested on 2 November 2021 after 9:30am UTC+2 onwards. We're working to ensure that the issue is fixed urgently.
Posted Nov 02, 2021 - 12:52 UTC
This incident affected: Bank deposits and withdrawals (South Africa).