Bitcoin network high transaction fees
Incident Report for Luno
Resolved
Network congestion has cleared and Bitcoin transaction fees have returned to normal.
Posted Apr 26, 2024 - 11:24 UTC
Update
Bitcoin transaction fees have come down significantly but remain much higher than normal.

Fees may be volatile over the next few days, we show the transaction fee before proceeding with an on-chain send. Please be sure to check it before sending BTC.

We're continuing to monitor.
Posted Apr 23, 2024 - 08:52 UTC
Identified
With the recent halving, we are seeing high transaction fees on the Bitcoin network.

High transaction fees on the Bitcoin network may result in longer confirmation times for transactions and increased costs for sending Bitcoin. Customers may experience delays in their transactions.

We are closely monitoring the situation and will provide updates as needed. For real-time information on Bitcoin transaction fees and network congestion you can refer to blockchain explorers.
Posted Apr 20, 2024 - 05:50 UTC