Delayed bank withdrawals in South Africa
Incident Report for Luno
Resolved
Withdrawals are being processed accordingly. Thank you.
Posted Feb 11, 2021 - 09:46 UTC
Update
We are currently experiencing technical issues with ZAR withdrawals.

We are working with our payment partner to resolve the situation as soon as possible and will keep you updated with any developments.

We expect the situation to be resolved by tomorrow morning
Posted Feb 09, 2021 - 13:49 UTC
Identified
There may be temporary delays with South Africa withdrawals requested on 8 February. We’re working with the bank to see this resolved soon.

We will attempt to release the withdrawals during the next release. You can find the full withdrawal schedule here: https://www.luno.com/help/articles/11000022934
Posted Feb 08, 2021 - 12:58 UTC