Deposits via PayID in Australia
Incident Report for Luno
Resolved
Our provider has confirmed issues with PayID deposits in Australia have been resolved.

Service for deposits using PayID have returned to normal.

Thanks for your patience.
Posted Feb 01, 2021 - 15:13 UTC
Identified
Our team has identified an issue with deposits via PayID in Australia. This may result in deposit delays of up to 30 minutes for customers who have signed up before 29 January while customers who have signed up on or after 29 January may not be able to deposit at all using this method.

Bank transfers remain unaffected.

We're working closely with the payments provider to see this resolved as quickly as possible. Thanks for your patience.
Posted Jan 29, 2021 - 10:05 UTC