Delayed bank withdrawal in Australia
Incident Report for Luno
Resolved
Withdrawals are now being processed as scheduled. Thank you
Posted Apr 06, 2021 - 07:31 UTC
Identified
Withdrawals in Australia will not be processed from 2nd April until 5th April due to the public holiday, unfortunately, banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 6th April.

Please view our full withdrawal schedule via the link below:
https://www.luno.com/help/articles/11000022934
Posted Apr 01, 2021 - 08:17 UTC
This incident affected: Bank deposits and withdrawals (Australia).