Intermittent deposit and withdrawals delays in Nigeria
Incident Report for Luno
Resolved
This incident has been resolved.
Posted Aug 04, 2020 - 11:10 UTC
Update
We are still experiencing some intermittent delays with deposits and withdrawals in Nigeria. Investigations with our service provider is still underway. We hope to have this resolved soon and will keep you updated
Posted Jul 29, 2020 - 11:22 UTC
Identified
We're aware of intermittent delays with deposits and withdrawals in Nigeria. Our team is currently investigating it and working with our service provider to get it resolved. We hope to have this resolved soon.
Posted Jul 25, 2020 - 20:23 UTC