Slow voucher withdrawals in Nigeria
Incident Report for Luno
Resolved
Withdrawals are being processed as normal, thanks for your patience.
Posted Nov 25, 2021 - 07:21 UTC
Identified
Some customers may experience delays in requesting withdrawals via vouchers in Nigeria, we hope to see this resolved as soon as possible. If you aren't able to process a withdrawal please try again in a few hours. We'll update this status page the minute anything changes.

Sincerely sorry about any inconvenience caused.
Posted Nov 24, 2021 - 14:07 UTC