Delayed bank withdrawals in Malaysia
Incident Report for Luno
Resolved
Withdrawals are being processed as normal.
Posted 3 months ago. Jun 07, 2019 - 09:18 UTC
Identified
Withdrawals in Malaysia will not be processed on 5 and 6 June 2019 due to the public holiday, unfortunately banks do not process withdrawals over weekends or public holidays.

Requested withdrawals will be processed on 7 June 2019.

Please view our full withdrawal schedule via the link below:

https://www.luno.com/help/articles/11000022934
Posted 3 months ago. Jun 05, 2019 - 07:34 UTC