Delay with incoming ETH transactions
Incident Report for Luno
Resolved
There are no further delays with ETH receives.
Posted Dec 28, 2020 - 06:51 UTC
Monitoring
ETH receive transactions are being processed as normal, we're monitoring closely for any further errors. Thanks for your patience.
Posted Dec 28, 2020 - 06:30 UTC
Investigating
We've identified an issue with incoming ETH transactions, affecting confirmations. This means that some customers may see a delay when receiving ETH.

The issue has been identified and a fix is being implemented.
Posted Dec 27, 2020 - 07:11 UTC