Delayed bank withdrawals in Europe
Incident Report for Luno
Resolved
We have resolved our issues with deposits and withdrawals. Payments are now being processed accordingly.

Thank you.
Posted Jul 03, 2020 - 15:07 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jul 02, 2020 - 16:38 UTC
Identified
There may be temporary delays with GBP and EUR deposits and withdrawals requested on 2nd July. We’re working with our bank to see this is resolved soon.

We will attempt to release the withdrawals during the next release. You can find the full withdrawal schedule here: https://www.luno.com/help/articles/11000022934
Posted Jul 02, 2020 - 16:21 UTC