Delayed bank deposits and withdrawals in Zambia
Incident Report for Luno
Resolved
Deposits and withdrawals in Zambia are now being processed accordingly.

Thank you for your patience.
Posted Nov 06, 2020 - 07:24 UTC
Identified
There may be temporary delays with deposits and withdrawals in Zambia requested from November 2nd. We’re working with the bank to see this resolved soon.
Posted Nov 03, 2020 - 09:06 UTC