Account verification delay in Nigeria
Incident Report for Luno
Resolved
Our verification partner has fixed the issue, we have managed to process all the affected and delayed account verification requests.
Posted Nov 23, 2021 - 09:17 UTC
Investigating
We have identified an issue with one of our account verification partners which is causing a delay with verifying a few selected customers. They are working on fixing the issue to restore full service shortly. The majority of our verification is still ongoing without interruption.
Posted Nov 22, 2021 - 11:12 UTC
This incident affected: Help & account verification (Account verification).