Bank transfer with Flutterwave disrupted ZA & NG
Incident Report for Luno
Resolved
Bank transfers from Flutterwave are clearing as normal, thanks for your patience.
Posted Jun 21, 2022 - 07:10 UTC
Update
We are continuing to investigate this issue.
Posted Jun 09, 2022 - 16:51 UTC
Investigating
We are currently experiencing an issue with card payments via Flutterwave.

We are looking into this as a matter of priority.

We apologise for any inconvenience.
Posted Jun 09, 2022 - 16:51 UTC
This incident affected: Bank deposits and withdrawals (South Africa, Nigeria).